More Program Configuration — Email (event) Notifications

Overview of Email Event Notifications: The purpose of the MaintSmart
Event Notification feature is to notify specified users by email when certain
type of important events take place.

The events are configurable by a MaintSmart administrator.

The following types of events can trigger Event Notification.

1. Work Order-Related Events

. Work Order Created

. Work Order Edited

Work Order Status Changed

Work Request Created

Work Request Edited

. Purchasing-Related Events

Quote Request Created

. Requisition Created

Requisition Status Changed

Requisition Line Item Approved

. Downtime-Related Events

. Downtime Created

. Downtime Edited
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The recipients of the Event Notification emails can be configured by a
MaintSmart administrator. Each event type can have a different list of
recipients.

1.) Sender (The MaintSmart user that performs the create or edit.)

2.) Work Requestor (Work Requests only.)

3.) MaintSmart Users with email addresses

4.) Arbitrary email addresses

Configuring Events and Email Addresses: To configure Event
Notifications navigate to the main Configuration screen and select menu
"View" > "Email Notifications". The Event Notification Configuration screen
will open and Event Notifications can be configured.

On this screen you can define up to one rule for each type of event per
plant. A rule consists of the type of event that will trigger the notification
and a set of users and email addresses to send the event notification to.
To create an event notification rule all that is necessary is to pick the type
event you want to create a rule for and specify the recipients to be notified
each time the event occurs. Status Change events require that you
specify which status values will trigger the event notification.
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More Program Configuration — Email (event) Notifications

Selecting Event Notification Recipients:
The sender or requestor is the MaintSmart user that creates or edits a MaintSmart item such as a Work Order. If you want the Sender to be notified when an event takes place, then place a
check in the "Notify Sender" or "Notify Sender/Requestor" check box.

Notifications may also be sent to any MaintSmart users for whom email information has been provided. Select from the list of users with emails in the left-hand ("Users") list box and click the
">" putton to move the user into the right-hand list box ("Send To Users"). To remove users from the list of "Send To Users" users, select the user to remove from the right-hand list box and
click the "<" button.

To enter arbitrary email addresses type or paste the email address into the "Email Addresses" text box and click the "+" button. The Email address will be added to the list box. To remove
an email address from the list box select it by clicking on it with the mouse and then either and click the "-" button or press the delete key.

A Note On Email Addresses: Only recipients with email addresses that have been entered in MaintSmart will be displayed in the "Users" list-box. Recipients and Emails that appear in the
"Users" and "Send To Users" list-boxes come from three different places in MaintSmart.

Users

Email addresses are used that were entered for MaintSmart Users in the "Program Configuration Settings" screen that is accessible from the MaintSmart toolbar: .

The name and email address that are displayed in the list-box are separated by an equal sign. For example: "Keith DeSilva = kdesilva@xyz.com".

Engineers (Applies only to Work Order events)

Email addresses are used that were entered for Engineers in the "Plant / Mechanic Configuration Screen"

The name and email address that are displayed in the list-box are separated by a hyphen. For example: "Jon Schank - jschank@xyz.com".

Requestors (Work Order Requestors)

Email addresses are used that were entered for Work Order Requestors in the " Work Order Requestors" that are accessible from the "Options" > "Requestors..." menu on the Work Order
entry screen.

The name and email address that are displayed in the list-box are separated by a tilde. For example: "Carol Cook ~ ccook@xyz.com".
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Cloning Event Notification Rules:

If you need to create a new rule and use the same or similar set of recipients as a rule that has already been created you may clone an existing rule. Cloning a rule will copy all of its
recipients into the rule entry form and all you will need to do is specify the rule type and optionally edit the set of recipients. To clone a rule you must not be currently editing or creating a
new rule. Right-click in the grid on the rule you want to clone and select the "Clone” menu item. . Type Plant Identifier | MotifyRequestor | Mot

ated Sacramento |:|

:questStatusChanged | Sacr
Clone
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More Program Configuration — Email Notifications for Work Order Events

Setting Up Work Order Event Notifications:

First, select the type of Work Order event.

Note that a Work Request differs from a Work Order in that it is created by a user who is a Work

Order Requestor and immediately after creation its status is "Request". ‘Work Order Event Notification Configuration
Plant: Event Type:

ISa:ramentc vl I

‘WOCreated

All Event Types for which rules have not yet been created will be displayed in the "Event Type"

drop-down box.
[T Motify Sender/Requestor WO StatusChanged
WOEdited
I™ MNotify Engineer(s) WorkReguestCreated

WorkRequestStatusChanged

Work Order Event Motification Configuration
Plant: Event Type:

| Sacramento j IWD StatusChanged j

] Motify Sender/Requestor
™ Motify Engineers)

Work Order Status: Change To Status:

' i3
In Progress ﬂ

If the type of Event Natification Rule is "WOStatusChanged" or "WorkRequestStatusChanged"”, then it is necessary to specify each status value for which the event will trigger a
notification. In the example shown, the notification will occur whenever the status of a Work Order is changed to "Done". Multiple status values can be selected for a single rule.

[~ Motify Sender/Reguestor
[ Motify Engineer(s)

f "Notify Sender/Requestor" is checked, then the user that created the Work Order will be notified.
If "Notify Engineer(s)" is checked, then all engineers (for whom email addresses have been entered in MaintSmart) that are assigned to a Work Order will be notified.
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More Program Configuration — Email Notifications for Purchasing Events

Setting Up Purchasing/Requisition Event Notifications: Event Type:
Purchasing Event Notifications notify users of the occurrence of events related to Quote Requests
and Requisitions. j
First, select the type of Purchasing event. PurchasingQuoteRequestCreated
. . . . Reguisition>tatusChanged
All Event Types for which rules have not yet been created will be displayed in the "Event Type" RequistionLinetemApproval

drop-down box.

—Purchasing Event Motification Configuration

Usen

Plant: Event Type:
IEacramertc j IR&quis'rtiunStatusChanged j

¥ Motify Sender/Requestor

Requisition Status: Change To Status:
Approval In Progress - b |

Mot Approved

Open
PO Closed = A |

If the type of Event Notification Rule is "RequisitionStatusChanged", then it is necessary to specify each status value for which the event will trigger a notification. In the example shown,
the natification will occur whenever the status of a Requisition is changed to "Approved”. Multiple status values can be selected for a single rule.

If "Notify Sender/Requestor" is checked, then the user that created the Quote Request or Requisition will be notified. Note that in the context of Purchasing Event Notifications, this is not
in any way related to a Work Order Requestor.
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More Program Configuration — Email Notifications for Downtime

Setting Up Downtime Event Notifications:
Downtime Event Notifications notify users of the occurrence of events related to Equipment
Downtime. First, select the type of Downtime event.

All Event Types for which rules have not yet been created will be displayed in the "Event Type"
drop-down box.

~Down Time Event Motification Configuration

Plant: Event Type: Users:

ISau:ra mento j IannﬂmeEd'rted j Charlie Huston
Minimum Severity: Christian Thom

¥ Motify Sender dave hackwor
| very High -

Email Address:

e

It is necessary to specify the minimum downtime Severity for which downtime Event Notifications will occur. In this example a minimum severity of Medium has been selected so Event
Notification will only occur for downtimes with severities of "Medium®”, "High", and "Very High." In other words, any downtimes with severities of "Very Low" and "Low" will not trigger Event
Notification. The cause ALL downtimes to trigger notifications, select the least severe state--the first severity value in the drop-down box (in this case "Very Low"). The "Minimum
Severity" drop-down box will always have the least severe state at the top and the most severe state at the bottom. Severities are sorted from least to most severe from top to bottom of

the drop-down box.
If "Notify Sender " is checked, then the user that entered the downtime will be notified.

Minimum Severity:

¥ Motify Sender
Very Low

fery Low

Medium
High
ery High
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More Program Configuration — Controlling How MaintSmart Checks for Events

Controlling How MaintSmart Checks for Events:

MaintSmart checks for events at a regular interval and sends emails for any events for which Event
Notifications have been configured. MaintSmart administrators can control how MaintSmart checks
for events from the "Configuration-More" tab on the Program Configuration Screen.

Configuration Senfiguration - More | s

Event Notification is activated by checking the "Automatically Refresh Event Notifications" Checkbox.
To set the interval in minutes at which MaintSmart checks for events enter the number of minutes in
the " Event Notification Scan Rate" box.

™ Global Meter Scanning (default = checked)
™ Global Schedule Scanning (default = checked)
IF Global Event Motification Scanning (default = checked) | AUTOMATCANY KETTESN UHLMEET LINK *  18NIYIG vaius i —w

| | Automatically Refresh Event Motifications
Meter Scan Rate (min.): Schedule Scan Rate (min.):

Event Motification Scan Rate (min_};

The Event Notification Scan Rate (minutes) determines how often the program P e
checks for events. _— | =

How To Use Parts For Metered Work Orders:

IAI'.'.' ays Create Work Order Even If Parts Shortages Exist j

Report Format ForMetered Work h
Print

=
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More Program Configuration — Viewing Event Notification History

Viewing Event Notification History:

Administrators can view the history of Event Notifications. From the Event Notification Configuration
screen select the "View" > "View Email Notification History" menu item or from the main Configuration
screen and select menu "View" > " View Email Notification History". The list of all Event Notification

View

records will be displayed.

£ Event Notification Configuration

| Options  Help
_/,__wmq} View Email Notification History

||se Events

Motification Type

DT SeverityLevel | NotifyR

L; NotRulelD

File
This will display the type of natification, dates, and the status of the Event Notification 1
(Pending, Sent, or SendFail) as well as some information on the Work Order, Requisition, or
Downtime that triggered the notification. The "Item ID" in the grid is the ID number of the 1

Work Order, Requisition, or Down Time that triggered the notification.

Purging Notification History: As time goes on there will be many old Event
Notification record accumulated and it will be desirable to purge the older

ones. Old Event Notification records can be purged using the Event Notification
History screen's "Options" menu. Choose the appropriate number of days past
which all Event Notification records should be deleted. Only records for the
current plant will be deleted or choose to delete all history. If any unsent
notifications are older than the specified time they will be deleted and will never
be sent. After the records are purged, a message will pop up informing you of the
number of records purged.

Copyright © 2014 MaintSmart Software, Inc. All Rights Reserved

/

Settings  Options  Translation

Window

Requestors...

Configure Skills...

Configure Customer Satisfaction Survey...

Configure Shifts. ..
Approval Level Configuration. ..

Email Configuration...
Email Motifications. ..

Configure Inventory Change Log Status

a5l Event Notification History

Options | Help

Purge Event Notification History Older Than 7 Days | |

uy Event Motification History

Purge Event Motification History Older Than 30 Da],rsl"'f
Purge Event Motification History Older Than 180 Days

Purge Event Motification History Older Than 365 Days

Purge All Event MNotification History

-
Eile Options Help
Mabification D | Matficabien Type | Created Sant Fedifieation Stshs [i2em 10 | Line lism Number | Lis:
10| WO ShabusChanged | B52016 1200 AM | B52016 12:00 AW | Sent 123 alo

"

WOS{ahisChan pad

GAER016 12.00 A0 | &S2016 12:00 AM

123

albly

25




